当前位置: 网站首页 > 股票软件公式 > 飞狐公式 > 文章 当前位置: 飞狐公式 > 文章

飞狐操盘指令,螺旋线指标,FZMOBV副图指标

点击: 次    来源:顶尖第四色色琪琪在线观看    作者:股市狙击 - 小 + 大

操盘指令:

VAR1:=1;

VAR2:=1;
VAR3:=EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16);
VAR4:=1/WINNER(CLOSE)*VAR1;
VAR5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR6:=100-ABS(VAR5);
VAR7:=(CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100;
VAR8:=SMA(VAR7,20,1)*VAR1;
VAR9:=SMA(VAR8,15,1);
VARA:=100-3*VAR8+2*VAR9;
VARB:=(((EMA(IF(VARA>REF(VARA,1),VARA,VARA-3),3))-50)*(-1)*2/2+50)/10;
VARC:=EMA(AMOUNT,13)/EMA(VOL,13);
VARD:=(VARC/REF(VARC,1)-1)*100;
VARE:=VOL/CAPITAL*100;
VARF:=(HIGH-LOW)/((HIGH+LOW)/2)*100;
VAR10:=(VARB+VARE)*VARF*VARD*VAR1;
VAR11:=REF(CLOSE,1);
VAR12:=(SUM(IF(CLOSE>VAR11,VOL,0),26))/(SUM(IF(CLOSE<=VAR11,VOL,0),26))*100;
VAR13:=IF(VAR12<70,70,VAR12);
VAR14:=(CLOSE-LLV(LOW,9))/(HHV(HIGH*VAR2,9)-LLV(LOW,9))*VAR1*100;
VAR15:=SMA(VAR14,3,1);
VAR16:=SMA(VAR15,3,1);
VAR17:=3*VAR15-2*VAR16*VAR1;
VAR18:=(CLOSE-LLV(LOW,26))/(HHV(HIGH*VAR2,26)-LLV(LOW,26))*100;
VAR19:=SMA(VAR18,6,1);
VAR1A:=SMA(VAR19,3,1)*VAR1;
VAR1B:=3*VAR19-2*VAR1A;
VAR1C:=(IF(CROSS(VAR17,VAR1B*VAR2) AND VAR1B*VAR2<20,-1,0))+(IF(CROSS(VAR1B,VAR17) AND VAR1B>80,1,0));
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR1E:=(VAR1D-MA(VAR1D,14))/(0.015*AVEDEV(VAR1D*VAR2,14))/2;
VAR1F:=(SMA(MAX(CLOSE-VAR11,0),6,1))/(SMA(ABS(CLOSE*VAR1-VAR11),6,1))*100;
VAR20:=LLV(LOW,36);
VAR21:=HHV(HIGH,36);
VAR22:=EMA((CLOSE-VAR20)/(VAR21-VAR20)*100,9)*VAR1;
VAR23:=(IF(VAR1E>100 AND VAR22>50 AND CLOSE>OPEN,0.5,0))+(IF(VAR1F>80 AND VAR22>50 AND CLOSE>OPEN,0.5,0));
VAR24:=(CLOSE-LLV(LOW,100))/(HHV(HIGH*VAR2,100)-LLV(LOW*VAR2,100))*100;
VAR25:=SMA(VAR24,21,1)*VAR1;
VAR26:=SMA(VAR15,3,1);
VAR27:=3*VAR25-2*VAR26;
VAR28:=IF(VAR27>80 AND VAR1F>88,0.5,0);
减四分一:IF(VAR10>50 AND VAR10<100 OR VAR1C+VAR23+VAR28>0,25,0);
减三分一:IF(VAR10>100 AND VAR10<200,33,0);
减二分一:IF(VAR10>200,50,0);
减三分二:IF(VAR3>1.1 AND VAR3<1.15 AND VAR3<REF(VAR3,1) OR VAR3>1.15 AND VAR3<REF(VAR3,1),67,0);
警示录:MAX(MAX(减四分一,减三分一),MAX(减二分一,减三分二));




螺旋线指标:

input:r(14,0,99),图宽mm(200,0,999),图高mm(100,0,999);
PX:=SYSPARAM(1);
PY:=SYSPARAM(6);
bx:=图宽mm/(SYSPARAM(3)-SYSPARAM(2));//K线单位距离
by:=图高mm/(SYSPARAM(4)-SYSPARAM(5));//价格单位距离
x:=if(BARPOS<=pX,pX-BARPOS,0)*bx;//定X值
y:=if(x<=r,SQRT(r*r-x*x),0)/by;//定Y值
x1:=if(BARPOS<=pX,0,BARPOS-pX)*bx;
y1:=if(x1<=r*2,SQRT(r*r*4-x1*x1),0)/by;
x2:=if(BARPOS<=pX-r/bx,0,BARPOS-pX+r/bx)*bx;
y2:=if(x2<=r*3,SQRT(r*r*9-x2*x2),0)/by;
x3:=if(BARPOS<=pX-r/bx,pX-BARPOS-r/bx,0)*bx;
y3:=if(x3<=r*5,SQRT(r*r*25-x3*x3),0)/by;
{顶尖第四色色琪琪在线观看:股票学院 }
PY+y;
PY-y;
PY-r/by+y1;
PY-r/by-y2;
PY+r/by-y3;




FZMOBV副图:

ABV:=MA((SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0))/25000,2);

M1:=EMA(ABV,13);
TJ:=(ABV-M1)*6;
TJ3:=(ABV-M1)/M1>0.2;
STICKLINE(1,ABV,REF(ABV,1),TJ,1),colorFF00;
STICKLINE(TJ3,ABV,REF(ABV,1),TJ,1),colorFF0000;
STICKLINE(ABV>M1,ABV,REF(ABV,1),1,1),colorFF;
STICKLINE(ABV<M1,ABV,REF(ABV,1),1,1),colorFF;
M11:EMA(ABV,12),LINETHICK2;
M22:EMA(ABV,26),LINETHICK2;

上一篇:飞狐缺口反转,资金监控,蛟龙入海指标

下一篇:飞狐异动测度,主力仓位,火焰量指标

推荐阅读