当前位置: 网站首页 > 亚洲男人天堂在线网软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

同花顺量比异动探底,趋势买卖顺势买入,MACD综合指标

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

量比异动探底:

VARAB:=IF(DATE<20201105 AND DATE>20000000,1,0);

2.4,COLORFF00FF;
4.5,COLOR00FF00;
7.5,COLORCCCCCC;
量比:VOL/MA(REF(VOL,1),5),COLORCCCCCC,LINETHICK0;
正常:IF(量比>=0.8 AND 量比<1.5,量比,0),COLORFF00FF,LINETHICK0;
温和:IF(量比>=1.5 AND 量比<2.5,量比,0),COLOR00FF00,LINETHICK0;
放量:IF(量比>=2.5 AND 量比<5,量比,0),coloryellow;
剧量:IF(量比>=5 AND 量比<10,量比,0),colorred ;
异动:IF(量比>=10,量比,0),colorblue;
地量:IF(量比<0.51,量比,0),colorred ;
量比预警:=量比>=5;
AA:=量比*3*VARAB;
STICKLINE(C>=O,0,AA,2.8,0),COLOR6666CC;
STICKLINE(C>=O,0,AA,2,0),COLOR7777DD;
STICKLINE(C>=O,0,AA,1,0),COLOR8888EE;
STICKLINE(C>=O,0,AA,0.5,0),COLOR9999FF;
STICKLINE(C<O,0,AA,2.8,0),COLORCC6666;
STICKLINE(C<O,0,AA,2,0),COLORDD7777;
STICKLINE(C<O,0,AA,1,0),COLOREE8888;
STICKLINE(C<O,0,AA,0.5,0),COLORFF9999;
STICKLINE(地量,0,AA,2.3,0),colorred ;
STICKLINE(正常,0,AA,0,0),COLORFF00FF;
STICKLINE(温和,0,AA,0,0),COLOR00FF00;
STICKLINE(放量,0,AA,0.5,0),coloryellow;
STICKLINE(剧量,0,AA,0.3,0), colorred;
STICKLINE(异动,0,AA,0.3,0),colorblue;
P:=55;
S:=8;
M1:=3;
JJ:=DYNAINFO(11);
VAR18:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR18-REF(VAR18,1))/REF(VAR18,1)*1000;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,colorred,LINETHICK1;
神:=EMA(财,M1),colorgreen,LINETHICK1;
BTJ1:=(C-JJ)/JJ<-0.03;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
BTJ3:=CROSS(财,神) AND 财<-0.3;
BTJ32:=CROSS(财,神) AND 财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND 财>1.618;
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
STJ83:=STJ81 AND STJ82;
DIFF:=(EMA(CLOSE,8) - EMA(CLOSE,55))*10,colorred;
DEAA:=EMA(DIFF,3),colorgreen;
庄:= BTJ11 AND BTJ2 AND BTJ3;
有庄:=FILTER(庄,55)*VARAB,colorwhite;
价:=C;
大盘:=EMA(INDEXC,500)/EMA(C,500);
大盘参考线:=INDEXC/大盘,COLORFFFF00;
VAR20:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR21:=(20*VAR20+19*REF(VAR20,1)+18*REF(VAR20,2)+17*REF(VAR20,3)+16*REF(VAR20,4)+15*REF(VAR20,5)+14*REF(VAR20,6)+13*REF(VAR20,7)+12*REF(VAR20,8)+11*REF(VAR20,9)+10*REF(VAR20,10)+9*REF(VAR20,11)+8* REF(VAR20,12)+7*REF(VAR20,13)+6*REF(VAR20,14)+5*REF(VAR20,15)+4*REF(VAR20,16)+3*REF(VAR20,17)+2*REF(VAR20,18)+REF(VAR20,21))/210;
VAR22:=EMA(VAR21,15);
VAR23:=HHV(CLOSE,90);
VAR24:=LLV(CLOSE,90);
VAR25:=VAR23-VAR24;
VAR26:=EMA((CLOSE-VAR24)/VAR25-0.5,14);
ZLSP:=VAR26*20*VARAB;
 
..............
 



趋势买卖顺势买入:

VARAB:=IF(DATE<20200805 AND DATE>20000000,1,0);//趋势买卖信号 顺势买入

MA60:MA(C,60),coloryellow,LINETHICK2;
BU:=BARSLAST(CLOSE=HHV(CLOSE,30));
SE:=BARSLAST(CLOSE=LLV(CLOSE,30));
KK1:=SE*VARAB;
KK2:=BU*VARAB;
LM1:=SE*VARAB;
LM2:=BU*VARAB;
OK:=KK1>KK2 AND LM1>LM2;
OK1:=KK1>KK2 AND LM1<LM2;
NOK:=KK2>KK1 AND LM2>LM1;
NOK1:=KK2>KK1 AND LM2<LM1;
STICKLINE(OK1,CLOSE,OPEN,8,0),COLORFF00FF;
STICKLINE(OK1,HIGH,LOW,0,0),COLORFF00FF;
STICKLINE(OK,CLOSE,OPEN,8,0),colorred;
STICKLINE(OK,HIGH,LOW,0,0),colorred;
DRAWICON(OK AND NOT(REF(OK,1)),LOW-0.02,4);
DRAWICON(NOK AND NOT(REF(NOK,1)),HIGH+0.06,5);
DRAWTEXT(OK AND NOT(REF(OK,1)),LOW-0.02,' 买');
DRAWTEXT(NOK AND NOT(REF(NOK,1)),HIGH+0.06,' 卖');
 
..........




MACD综合(顶尖财经:亚洲男人天堂在线网学院 ):


VARAB:=IF(DATE<20201105 AND DATE>20000000,1,0);

DIFF:EMA(CLOSE,10)-EMA(CLOSE,22);
DEA:EMA(DIFF,5)*VARAB,COLORFFAA00;
MACD:=2*(DIFF-DEA)*VARAB;
STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,4,1),colorwhite;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,4,0 ),COLOR00AAFF;
X1:IF(DIFF<0,DIFF,0),COLOR0000FF,LINETHICK2;
X2:IF(DIFF<0,0,DIFF),colormagenta,LINETHICK1;
X3:IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;
X4:IF(DIFF>DEA,DEA,DEA),LINETHICK1,COLORFFBB11;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,DEA*0.86,DEA*0.66,6,0),coloryellow;
DRAWTEXT(低位金叉,DEA*0.86,' 低'),coloryellow;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,DEA*0.96,DEA*0.76,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.1,'BUY') ;
DRAWTEXT(二次金叉,DEA*0.96,' 二叉'),COLORFF3300;
 
..........

上一篇:同花顺愚人能量潮,独狼预警副图,启动指标

下一篇:同花顺箱体买入支撑压力,量比异动探底,趋势买卖顺势买入指标