当前位置: 网站首页 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码:介入捕捉启动股抄底时机,复盘放宽 筹码穿透 筹码集中度

点击: 次    来源:顶尖第四色色琪琪在线观看    作者:股市狙击 - 小 + 大

介入捕捉启动股抄底时机:

没有未来函数

V1:=LLV(LOW,10);
V2:=HHV(H,25);
RSV:=(((CLOSE - LLV(LOW,33)) / (HHV(HIGH,33) - LLV(LOW,33))) * 100);
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
动能:SMA(RSV,7,1),COLORWHITE,LINETHICK2;
运行:SMA(SMA(RSV,7,1),3,1),COLORBROWN,LINETHICK2;
趋势: IF(VAR6>45,VAR6-45,0);
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),2,0),COLORMAGENTA;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),2,0),COLORGREEN;
强弱分界:50,COLORFFFFCC;
底部:0,COLOR00FFFF;
安全:20,COLORFFAA66,LINETHICK1;
预警:80,COLORFFAA66,LINETHICK1;
顶部:100,COLORFFFF33;
Y3:(((CLOSE/COST(13))<=0.8)*10),COLORBLACK;
红柱:IF("MACD.MACD">REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),STICK,COLORRED;
绿柱:IF("MACD.MACD"<REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),STICK,COLORYELLOW;
轨迹:SMA(SMA(SMA(RSV,6,1),5,1),3,1),COLORMAGENTA,LINETHICK2;
价位线:=EMA((C-V1)/(V2-V1)*4,4);
抄底:ABS((CROSS("MACD.DIF","MACD.DEA")&&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.50,COLORLIMAGENTA;
DIF:"MACD.DIF",COLORWHITE;
DEA:"MACD.DEA",COLORYELLOW;
DRAWTEXT(CROSS(价位线,0.3),20+4,'买'),COLORRED;
DRAWTEXT(CROSS(3.5,价位线),100-4,'卖'),COLORGREEN;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
强度:IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;
强度2:IF(DEA<DIF,DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
吸筹:STICKLINE(VAR9Q>-120,0,VAR9Q,3,1),COLORYELLOW;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
DRAWTEXT(CROSS(动能,23),10,'机会');
介入时机选择线:20,COLORYELLOW,LINETHICK2;
卖临界:STICKLINE(走势-AA6>85,103,100,15,1),COLORRED,LINETHICK2;
主力线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*
SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK1,POINTDOT;
WWW58188COM:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
超短线:(((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))*(25),LINETHICK2,COLORLIRED;
VAR11:=3;
VAR21:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,
1))-(2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
股价准备启动:IF(CROSS(VAR21,VAR11),100,0),COLORRED,LINETHICK2;
DRAWTEXT(ABS(抄底)>0,抄底*1.20,' 抄底'),COLORYELLOW;
DRAWICON(ABS(抄底)>0,抄底*1.10,4);
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);




复盘放宽 筹码穿透 筹码集中度:

这个是股池选股策略,(顶尖第四色色琪琪在线观看 股票学院: www.58188.com)

一共用到3个公式:

筹码穿透率和集中度是技术指标,

复盘放宽  是选股。
 

{筹码穿透}

穿越筹码:ABS(WINNER(CLOSE)-WINNER(OPEN))*100,STICK,COLORDDDDFF;

换手率:=VOL/CAPITAL*100,STICK,COLORFF0099;

A1:=LLV(HIGH,240);

MYP:=100*(CLOSE-A1)/A1;

A2:=REF(HHV(CLOSE,240),1);

B2:=REF(LLV(CLOSE,240),1);

RPY:=100*(CLOSE -B2)/(A2-B2);

A3:=1.1*CLOSE;

B3:=0.9*CLOSE;

ASR:=100*(WINNER(A3)-WINNER(B3));

A4:=WINNER(CLOSE);

A5:=DMA(A4,VOL/CAPITAL);

B4:=DMA(VOL,VOL/CAPITAL)/CAPITAL;

A6:=100*VOL/CAPITAL;

B6:=100*(WINNER(CLOSE)-REF(WINNER(CLOSE),1));

A7:=ABS(B6/A6);

CYA:=A4/B4*50,COLORYELLOW;

CYB:=EMA(A4/B4*50,34),COLORFF00FF,LINETHICK2;

CYF:=A5/B4*50,COLORFFFF99,LINETHICK2;

CYD:=WINNER(CLOSE)/(VOL/CAPITAL),COLORYELLOW,STICK,LINETHICK4;

筹码穿透率:B6/A6;

获利比例:WINNER(C)*100,COLORGREEN;

 主力筹码估算:=EMA(WINNER(CLOSE)*70,3),NODRAW;

 散户筹码估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;

 散户套牢比率:=散户筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;

 主力控盘比率:主力筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;

 
{筹码集中度}
 
VAR1:=COST(10)*0.000;
VAR2:=IF(YEAR=2001 AND MONTH>7, 0, 1);
九十筹码密集度:(COST(95)-COST(5))/CLOSE*100*VAR2;
七十筹码密集度:(COST(85)-COST(15))/CLOSE*100*VAR2;
尖峰价:= COST(50);{平均成本线}
筹码1:=WINNER(尖峰价*0.90); {也可调成0.95}
筹码2:=WINNER(尖峰价*1.1); {也可调成1.05}
筹码集中度: (筹码2-筹码1)*100;
上界: 100,POINTDOT;
 
{复盘放宽}

VA1:=HHV(HIGH,9)-LLV(LOW,9);     

VA2:=HHV(HIGH,9)-CLOSE;

VA3:=CLOSE-LLV(LOW,9);

VA4:=VA2/VA1*100-70;

VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

VA6:=(CLOSE+HIGH+LOW)/3;

VA7:=SMA(VA3/VA1*100,3,1);

VA8:=LLV(LOW,34);

VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);

VARA:=IF(VA9>100,VA9-100,0);

VARB:=HHV(HIGH,34);

VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);

VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);

VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;

VARF:=MA(VARE,3);

VAR1:=HHV(HIGH,9)-LLV(LOW,9);

VAR2:=HHV(HIGH,9)-CLOSE;

VAR3:=CLOSE-LLV(LOW,9);

VAR4:=((VAR2)/(VAR1))*(100)-70;

VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);

VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);

VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);

VAR8:=LLV(LOW,34);

VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);

VAR10:=IF((VAR9>100),VAR9-100,0);

VAR11:=HHV(HIGH,34);

B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);

领先:=EMA(B1,5);

生命线:=EMA(VARD,1);

V1:=MA(C,5)=HHV(MA(C,5),20);

V2:=MA(C,5)>MA(C,10);

V3:=MA(V,5)>MA(V,40)*1.01;

V4:=COUNT(MA(C,1)>REF(C,1),2)=2;

VV:=V1 AND V2 AND V3 AND V4;

A1:=EMA(CLOSE,8);

A2:=EMA(A1,20);

A3:=CROSS(A1,A2);

A4:=A1<EMA(CLOSE,120);

A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2* SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1);

安全位:=20;

低位转强:=CROSS(A5,安全位);

开始拉升:=CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O;

A6:=LLV(C,500)=LLV(C,5) AND C/REF(C,1)>(1+9.8/100);

极地上涨:=A6 AND 领先;

转强:=低位转强+开始拉升+极地上涨>=1;

A:=SUM(IF(CURRBARSCOUNT=3,INDEXC,0),0);

B:=SUM(IF(CURRBARSCOUNT=1,INDEXC,0),0);

E:=SUM(IF(CURRBARSCOUNT=3,CLOSE,0),0);

F:=SUM(IF(CURRBARSCOUNT=1,CLOSE,0),0);

TJ1:=((F-E)/E)>(((B-A)/A)+0.01);

TJ2:=100*SUM(VOL,4)/CAPITAL>=10;

XG:COUNT(转强,4)>0 AND TJ1 AND TJ2 AND FINANCE(40)<4000000000 AND BARSCOUNT(C)>20 AND C/REF(C,1)>1.096  AND DYNAINFO(8)>0 AND NOT(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S'));

上一篇:通达信源码:资金进出,筹码堆积

下一篇:通达信公式下载:九五至尊量柱,抓牛 牛1号,顶底主图