当前位置: 网站首页 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码:十五指标共振,暴涨,分时资金进出

点击: 次    来源:顶尖第四色色琪琪在线观看    作者:股市狙击 - 小 + 大

十五指标共振:

无未来函数 做了个15个指标共振,
一直用 超准 八周期的共振副图指标
使用方法:大多情况  底部钻石没了  我就卖了

65,COLORBLACK;
DIF60:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
DEA60:=EMA(DIF60,9/2);
STICKLINE(DIF60>=DEA60,54,58,3,0),COLORRED;
STICKLINE(DIF60<DEA60,54,58,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,56,'★60分钟MACD★'),COLORWHITE;
 
RSV60:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36));
K60:=SMA(RSV60,3,1);
D60:=SMA(K60,3,1);
STICKLINE(K60>= D60,60,64,3,0),COLOR00FFFF;
STICKLINE(K60 < D60,60,64,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,62,'★60分钟KDJ★ '),COLORWHITE;
 
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
STICKLINE(DIF>=DEA,48,52,3,0),COLOR00BBBB;
STICKLINE(DIF<DEA,48,52,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,50,'★MACD日线★'),COLOR00FFFF;
周MD:=MACD.DIF#WEEK;
周MA:=MACD.DEA#WEEK;
STICKLINE(周MD>=周MA,42,46,3,0),COLOR00BBBB;
STICKLINE(周MD<周MA,42,46,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,44,'★MACD周线★'),COLOR00FFFF;
月MD:=MACD.DIF#MONTH;
月MA:=MACD.DEA#MONTH;
STICKLINE(月MD>=月MA,36,40,3,0),COLOR00BBBB;
STICKLINE(月MD<月MA,36,40,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,38,'★月MACD★'),COLORWHITE;
 
RSV:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12));
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D; 
STICKLINE(K>=D,30,34,3,0),COLORFF00FF;
STICKLINE(K<D,30,34,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,32,'★KDJ日线★'),COLORFFFFFF;
 
 
周K:=MA("KDJ.K#WEEK"(9,3,3) ,5);
 
周D:=MA("KDJ.D#WEEK"(9,3,3) ,5);
 
周J:=MA("KDJ.J#WEEK"(9,3,3) ,5);
STICKLINE(周K>=周D,24,28,3,0),COLORRED;
STICKLINE(周K<周D,24,28,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,26,'★KDJ周线★'),COLORWHITE;
月K:="KDJ.K#MONTH" ;
月D:="KDJ.D#MONTH" ;
STICKLINE(月K>=月D,18,22,3,0),COLORFF00FF;
STICKLINE(月K<月D,18,22,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,20,'★KDJ月线★'),COLORWHITE;
 
{RSI日}
日RSI1:="RSI.RSI1#DAY"(9);
日RSI2:="RSI.RSI2#DAY"(9);
STICKLINE(日RSI1>=日RSI2,12,16,3,0),COLOR990066;
STICKLINE(日RSI1<日RSI2,12,16,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,14,'★日R金叉★'),COLORFFFFFF;
{RSI周}
周RSI1:="RSI.RSI1#WEEK"(9);
周RSI2:="RSI.RSI2#WEEK"(9);
STICKLINE(周RSI1>=周RSI2,6,10,3,0),COLOR990066;
STICKLINE(周RSI1<周RSI2,6,10,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,8,'★周R金叉★'),COLORFFFFFF;
{RSI月}
月RSI1:="RSI.RSI1#MONTH"(9);
月RSI2:="RSI.RSI1#MONTH"(9);
STICKLINE(月RSI1>=月RSI2,0,4,3,0),COLOR990066;
STICKLINE(月RSI1<月RSI2,0,4,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=98,2,'★月R金叉★'),COLORFFFFFF;
 
STICKLINE(周K>=REF(周K,1),-6,-2,3,0),COLORRED;
STICKLINE (周K<REF(周K,1),-6,-2,3,0),COLOR333333;
DRAWTEXT(CURRBARSCOUNT=98,-4,'★周K拐头★'),COLOR00FFFF;
 
 
STICKLINE(周J>=REF(周J,1),-12,-8,3,0),COLORRED;
 
STICKLINE(周J<REF(周J,1),-12,-8,3,0),COLOR333333;
 
DRAWTEXT(CURRBARSCOUNT=98,-10,'★周J拐头★'),COLORFFFFFF;
 
 
VOLUME:=VOL,VOLSTICK;
 
MAVOL1:=MA(VOLUME,5);
 
MAVOL2:=MA(VOLUME,10);
 
STICKLINE(MAVOL1>=MAVOL2,-18,-14,3,0),COLORBLUE;
 
STICKLINE (MAVOL1<MAVOL2,-18,-14,3,1),COLOR333333;
 
DRAWTEXT(CURRBARSCOUNT=98,-16,'★成交量★'),COLORFFFFFF;
 
PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF
(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));
HSL:=(XVL/20)/1.15;
攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
资金流量:=LLJX,LINETHICK0,COLOR0000FF;
 
A10:=资金流量>0;
 
STICKLINE(资金流量>=0,-24,-20,3,0),COLORYELLOW;
 
STICKLINE (资金流量<0,-24,-20,3,1),COLOR333333;
 
DRAWTEXT(CURRBARSCOUNT=98,-22,'★资金流量★'),COLORFFFFFF;
 
DRAWICON(周K>=REF(周K,1) AND DIF60>=DEA60,-30,25);
 
 
{1指.能量线}
能量线:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3),LINETHICK0;
{2指.RSI}
RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100,LINETHICK0;
{3指.KDJ}
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK0;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1,LINETHICK0;
{4指.W&R}
威廉WR:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100,LINETHICK0;
{5指.CCI}
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
 
五指A:WMA((能量线+RSI+J-威廉WR+CCI)/5,5);
五指B:WMA((能量线+RSI+J-威廉WR+CCI)/5,13);
 
WMA((能量线+RSI+J-威廉WR+CCI)/5,5),COLOR00FF00,LINETHICK3;
IF(五指A>REF(五指A,1),五指A,DRAWNULL),COLOR0000FF,LINETHICK3;
 
 
DRAWTEXT_FIX(1,0.02,0,0,'能量线,RSI3.KDJ,W&R,CCI,五个指标共振线.[红].[绿].变化是买卖信号.颜色及标记是配合信号,重点关注60分MACD和周K拐头,周K金叉'),COLORRED,LINETHICK3;
 
 
KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
AAX:=(KC-MA(KC,9))/MA(KC,9)*100;
VAR0:=MIN(EXIST(KC,55),9);
AAX1:=EMA(AAX,VAR0)*VAR0;
AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5);
卖:=AAX3>3  AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1);
VBA:=FILTER(卖,5);
DRAWTEXT(VBA,五指A*1.08,'★卖出'),COLORGREEN;
DRAWICON(FILTER(VBA=1,3),40,2),COLORFFFF00;
STICKLINE(FILTER(VBA=1,5),36,0,1.25,0),COLORBLUE;
STICKLINE(FILTER(VBA=1,5),35,0,0.35,1),COLORBLUE,COLORGREEN;
VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
VB4:=FILTER(VB3=1,5);
DRAWTEXT(VB4,五指A*1,'★买入'),COLORD9D919;
 
DRAWICON(FILTER(VB4=1,3),40,1),COLORFFFF00;
STICKLINE(FILTER(VB4=1,5),36,0,1.25,0),COLORRED;
STICKLINE(FILTER(VB4=1,5),35,0,0.35,1),COLORRED,COLORYELLOW;
 
 
震幅0:=(H-L)/REF(C,1)*100; 
震幅:震幅0,NODRAW,COLORRED;
 
超级大盘股:FINANCE(7)>=8000000000,COLORRED,NODRAW;
大盘股:FINANCE(7)<8000000000 AND FINANCE(7)>=800000000,COLORYELLOW,NODRAW;
中盘股:FINANCE(7)<800000000 AND FINANCE(7)>=400000000,COLORGREEN,NODRAW;
小盘股:FINANCE(7)<400000000,COLORWHITE,NODRAW;
盘小绩优:FINANCE(7)<1000000000 AND DYNAINFO(39)>0 AND DYNAINFO(39)<=28,COLOR9933FF,NODRAW;
换手率:V/CAPITAL*100 NODRAW;




暴涨:

无未来函数 暴涨这个公式是捕捉启动点的公式,

公式只是一个工具  要设置好止损点
 

MA5:=MA(C,5);

MA10 :=MA(CLOSE,10);

MA60 :=MA(CLOSE,60);

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));

GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));

GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));

GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));

BAIJIN1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;

BAIJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;

BAIJIN3:=GJTJ1>60 AND GJTJ4>70;

XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5 AND GJTJ1>GJTJ4;

暴涨:IF(COUNT(XG,3)=1 AND XG AND C>MA(C,20),1,0),COLORRED,LINETHICK2;




分时资金进出:

可以看资金的进出的公式(顶尖第四色色琪琪在线观看 股票学院: www.58188.com)

VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;

主力撤退:IF(VAR1<0,VAR1,0),COLORFEDCBA,LINETHICK2;

主力:IF(VAR1>0,VAR1,0),COLORRED,LINETHICK2;

V1:=(C*2+H+L)/4*10;

V2:=EMA(V1,13)-EMA(V1,34);

V3:=EMA(V2,5);

V4:=2*(V2-V3)*5.5;

大户撤退:IF(V4<0,V4,0),COLOR00FF00;

大户:IF(V4>0,V4,0),COLORFF00FF;

V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;

V6:=EMA(3*V5-2*SMA(V5,18,1),5);

V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;

V8:=(INDEXC*2+INDEXH+INDEXL)/4;

V9:=EMA(V8,13)-EMA(V8,34);

VA:=EMA(V9,3);

VB:=(V9-VA)/2;

大资金进场VB: IF(VB>=0,VB,0),COLORYELLOW,LINETHICK2;

大资金离场:IF(VB<=0,VB,0),COLORBLUE,LINETHICK2;

零为分界线:0,COLORWHITE,LINETHICK2;

DRAWTEXT(ISLASTBAR AND C,VAR1,'  主力线:零轴上方可进场 中线可持股'),COLOR0000BB;

DRAWTEXT(ISLASTBAR AND C,V4,'  大户线:零轴下方短线必出且不抄底'),COLOR0000BB;

DRAWTEXT(ISLASTBAR AND C,VB,'  大资金线:零轴下方需小心,第四色色琪琪在线观看家公式网'),COLOR0000BB;

上一篇:通达信源码:分时涨停预警,威力巨大主图,抄底小王子

下一篇:通达信源码:骗线拐点,关注一字板,双金叉